Minimum MySQL Version Required to run WordPress

New Chart – Minimum MySQL Version

Rami Yushuvaev 0 Comments

Introducing the Minimum MySQL Version chart. Historical chart displaying the minimum MySQL version required to run each major WordPress version.

Source

The official requirements are available on the “Requirements” page on WordPress.org. In addition, the required MySQL version is defined in the version.php file.

History

With the release of WordPress 2.0  in 2005, the minimum required versions set to MySQL 3.23.23. In 2007, when WordPress 2.1 was released, MySQL 3 was abandoned in favor of MySQL 4.0. At the end of 2009 with the release of WordPress 2.9 the minimum version was updated again to MySQL 4.1.2. The last update happened in 2011 when WordPress 3.2 abandoned MySQL 4.x in favor of MySQL 5.0.15.

Insights

The minimum required MySQL version was upgraded 4 times, each time 4 year apart (2005, 2007, 2009 and 2011). Just like the last PHP upgrade, the last MySQL minimum requirement upgrade was 6 years ago. The current minimum MySQL version has already reached EOL (End of Life) and it is no longer supported.

Have any insights? Share them in the comments area below.

Rami Yushuvaev

I'm an entrepreneur, a web developer and a blogger. I’ve contributed code to each and every WordPress release since version 2.8. I am the Hebrew GTE since WordPress 3.3, responsible for the translation and the release of WordPress Hebrew version. And a core developer for WordPress 4.4, 4.6, 4.7 and 5.2. I am also the founder of GenerateWP.com and several other WordPress related projects. But mainly I work with Israeli startups, providing WordPress Plugin development services.

Leave a Reply

Your email address will not be published. Required fields are marked *