WordPress Minimum MySQL Version

Minimum MySQL Version Required to run WordPress

Data Sources

The raw data for this chart is based on the official “Requirements” page in WordPress.org.

In addition, since WordPress 2.9 the required MySQL version for each WordPress version is defined in version.php file.

History

WordPress 2.0 was the first version to set minimum required MySQL version – it was decided to use MySQL 3.23.23.

Two years later, on January 2007, WordPress 2.1 was released with upgraded minimum required MySQL version – adopting MySQL 4.0.

After three more years, on December 2009, WordPress 2.9 was released with new minimum required MySQL version – this time is was MySQL 4.1.2 [ Source ]. In this version the required PHP and MySQL versions added to version.php file.

In mid 2010, the developers announced the end of support for PHP 4 and MySQL 4 as of WordPress 3.2 [ Source ]. When 3.2 was released on July 2011, the new minimum required version was MySQL 5.0.15 [ Source ].

The recommended version is MySQL 5.6 or greater [ Source ].

Historical MySQL Requirements

4.9MySQL version 5.0.15 or greater.
4.8MySQL version 5.0.15 or greater.
4.7MySQL version 5.0.15 or greater.
4.6MySQL version 5.0.15 or greater.
4.5MySQL version 5.0.15 or greater.
4.4MySQL version 5.0.15 or greater.
4.3MySQL version 5.0.15 or greater.
4.2MySQL version 5.0.15 or greater.
4.1MySQL version 5.0.15 or greater.
4.0MySQL version 5.0.15 or greater.
3.9MySQL version 5.0.15 or greater.
3.8MySQL version 5.0.15 or greater.
3.7MySQL version 5.0.15 or greater.
3.6MySQL version 5.0.15 or greater.
3.5MySQL version 5.0.15 or greater.
3.4MySQL version 5.0.15 or greater.
3.3MySQL version 5.0.15 or greater.
3.2MySQL version 5.0.15 or greater.
3.1MySQL version 4.1.2 or greater.
3.0MySQL version 4.1.2 or greater.
2.9MySQL version 4.1.2 or greater.
2.8MySQL version 4.0 or greater.
2.7MySQL version 4.0 or greater.
2.6MySQL version 4.0 or greater.
2.5MySQL version 4.0 or greater.
2.3MySQL version 4.0 or greater.
2.2MySQL version 4.0 or greater.
2.1MySQL version 4.0 or greater.
2.0MySQL version 3.23.23 or greater.
1.5MySQL version 0 or greater.
1.2MySQL version 0 or greater.
1.0MySQL version 0 or greater.
0.7MySQL version 0 or greater.