WordPress Minimum PHP Version

Minimum PHP Version Required to run WordPress

Data Sources

The raw data for this chart is based on the official “Requirements” page in WordPress.org.

In addition, since WordPress 2.9 the required PHP version for each WordPress version is defined in version.php file.

History

WordPress 2.0 was the first version to set minimum required PHP version – it was decided to use PHP 4.2.

Two years later, on March 2008, WordPress 2.5 was released with upgraded minimum required version – adopting PHP 4.3 [ Source ].

In mid 2010, the core team announced the end of support for PHP 4 and MySQL 4 as of WordPress 3.2 [ Source ]. When 3.2 was released on July 2011, the new minimum required version was PHP 5.2.4 [ Source ].

Today, the minimum required version has reached the official End-Of-Life [ Source ] and as such may expose your site to security vulnerabilities. The recommended version is PHP 7 or greater [ Source ].

Historical PHP Requirements

4.9PHP version 5.2.4 or greater.
4.8PHP version 5.2.4 or greater.
4.7PHP version 5.2.4 or greater.
4.6PHP version 5.2.4 or greater.
4.5PHP version 5.2.4 or greater.
4.4PHP version 5.2.4 or greater.
4.3PHP version 5.2.4 or greater.
4.2PHP version 5.2.4 or greater.
4.1PHP version 5.2.4 or greater.
4.0PHP version 5.2.4 or greater.
3.9PHP version 5.2.4 or greater.
3.8PHP version 5.2.4 or greater.
3.7PHP version 5.2.4 or greater.
3.6PHP version 5.2.4 or greater.
3.5PHP version 5.2.4 or greater.
3.4PHP version 5.2.4 or greater.
3.3PHP version 5.2.4 or greater.
3.2PHP version 5.2.4 or greater.
3.1PHP version 4.3 or greater.
3.0PHP version 4.3 or greater.
2.9PHP version 4.3 or greater.
2.8PHP version 4.3 or greater.
2.7PHP version 4.3 or greater.
2.6PHP version 4.3 or greater.
2.5PHP version 4.3 or greater.
2.3PHP version 4.2 or greater.
2.2PHP version 4.2 or greater.
2.1PHP version 4.2 or greater.
2.0PHP version 4.2 or greater.
1.5PHP version 0 or greater.
1.2PHP version 0 or greater.
1.0PHP version 0 or greater.
0.7PHP version 0 or greater.