Minimum PHP Version Required to run WordPress

New Chart – Minimum PHP Version

Rami Yushuvaev 0 Comments

Introducing the Minimum PHP Version chart. Historical chart displaying the minimum PHP version required to run each major WordPress version.


The official requirements are available in the “Requirements” page on In addition, the required PHP version is defined in the version.php file.


With the release of WordPress 2.0  in 2005, the minimum required version was set to PHP 4.2. In 2008, when  WordPress 2.5 was released, PHP 4.2 got abandoned in favor of PHP 4.3. The last update was in 2011 when WordPress 3.2 abandoned PHP 4.x in favor of PHP 5.2.


WordPress has always tried to build flexible software that runs on common server configurations. But over the years, several PHP versions reached their official End-Of-Life. Therefore WordPress had to update the minimum required PHP version.

Upgrading to newer PHP versions allows developers to use newer standards, efficient code, faster processing and many more obvious advantages. On the other hand, it requires hosting companies to invest money in software upgrades and new infrastructure. Not many companies do these upgrades.

Anyway, from the data I learned that WordPress updated the minimum required PHP versions 3 times, each time 3 year apart (2005, 2008 and 2011). But the last update was 6 years ago. The current minimum PHP version has already reached EOL and it is no longer supported. This is why I predict that in 2018 WordPress is expected to abandon officially PHP 5 in favor of PHP 7.

Have any insights? Share them in the comments area below!

Rami Yushuvaev

I'm a fullstack developer, a blogger and an entrepreneur. I contribute to open source projects. Creator of,, and many other projects. I work mainly with Israeli startups, providing development services.

Leave a Reply

Your email address will not be published. Required fields are marked *