WordPress Minimum PHP Version

Minimum PHP Version Required to run WordPress

Data Sources

The raw data for this chart is based on the official “Requirements” page in WordPress.org.

In addition, since WordPress 2.9 the required PHP version for each WordPress version is defined in version.php file.

History

WordPress 2.0 was the first version to set a minimum required PHP version – it was decided to use PHP 4.2.

Two years later, on March 2008, WordPress 2.5 was released with upgraded minimum required version – adopting PHP 4.3 [ Source ].

Another two years have passed and on July 2011 WordPress 3.2 bumped the the minimum required version to PHP 5.2.4 [ Source ]. A part of larger process to end the support for PHP 4 and MySQL 4 as of WordPress 3.2 [ Source ].

Nine years later, on May 2019, WordPress 5.2 bumped the minimum required version to PHP 5.6.20 [ Source ].

A year later, on June 2020, the minimum required PHP version was bumped to PHP 7.2 [ Source ]. A decision that will end the support of PHP 5. This should apply only on future WordPress releases.

Historical Data

5.5PHP version 5.6.20 or greater.
5.4PHP version 5.6.20 or greater.
5.3PHP version 5.6.20 or greater.
5.2PHP version 5.6.20 or greater.
5.1PHP version 5.2.4 or greater.
5.0PHP version 5.2.4 or greater.
4.9PHP version 5.2.4 or greater.
4.8PHP version 5.2.4 or greater.
4.7PHP version 5.2.4 or greater.
4.6PHP version 5.2.4 or greater.
4.5PHP version 5.2.4 or greater.
4.4PHP version 5.2.4 or greater.
4.3PHP version 5.2.4 or greater.
4.2PHP version 5.2.4 or greater.
4.1PHP version 5.2.4 or greater.
4.0PHP version 5.2.4 or greater.
3.9PHP version 5.2.4 or greater.
3.8PHP version 5.2.4 or greater.
3.7PHP version 5.2.4 or greater.
3.6PHP version 5.2.4 or greater.
3.5PHP version 5.2.4 or greater.
3.4PHP version 5.2.4 or greater.
3.3PHP version 5.2.4 or greater.
3.2PHP version 5.2.4 or greater.
3.1PHP version 4.3 or greater.
3.0PHP version 4.3 or greater.
2.9PHP version 4.3 or greater.
2.8PHP version 4.3 or greater.
2.7PHP version 4.3 or greater.
2.6PHP version 4.3 or greater.
2.5PHP version 4.3 or greater.
2.3PHP version 4.2 or greater.
2.2PHP version 4.2 or greater.
2.1PHP version 4.2 or greater.
2.0PHP version 4.2 or greater.
1.5No minimum PHP requirements.
1.2No minimum PHP requirements.
1.0No minimum PHP requirements.
0.7No minimum PHP requirements.